Degraded Performance in APIs
Incident Report for Click2Mail
Resolved
The issue with degraded performance on our APIs has been resolved.
Posted Mar 19, 2024 - 18:11 UTC
Monitoring
We have applied the fix and we will continue to monitor the performance of our APIs.
Posted Mar 19, 2024 - 12:54 UTC
Identified
We have identified the issue and applied a fix. Performance of the REST API and Batch API should be back to normal.
Posted Mar 19, 2024 - 12:53 UTC
Investigating
We are still investigating performance degradation issues in our REST and Batch APIs
Posted Mar 18, 2024 - 15:55 UTC
This incident affected: REST API and Batch API.