Batch Errors, Possible Rest Errors related

Incident Report for Click2Mail

Resolved

This incident has been resolved.
Posted May 05, 2026 - 11:12 UTC

Update

We are continuing to investigate this issue.
Posted May 05, 2026 - 01:53 UTC

Investigating

We are aware that some customers are receiving errors submitting jobs through our Batch API. We also have a report of errors submitting REST jobs. We are investigating this.
Posted May 05, 2026 - 00:14 UTC
This incident affected: REST API, Batch API, and MailJack+.